Discourse Maintenance
Incident Report for Popcorn Time
Resolved
Updates complete!
Posted about 2 years ago. Jan 20, 2015 - 10:32 UTC
Update
Updates are taking longer than expected. Sorry!
Posted about 2 years ago. Jan 20, 2015 - 10:13 UTC
Identified
Forums are currently going through an update cycle. Should be back ASAP!
Posted about 2 years ago. Jan 20, 2015 - 09:54 UTC