Android Movies outage
Incident Report for Popcorn Time
Resolved
Android app has been updated with a new version that fixes issues with movies
Posted over 2 years ago. Mar 09, 2015 - 21:57 UTC
Identified
Movies on the Android app are currently unavaliable
Posted over 2 years ago. Mar 08, 2015 - 21:51 UTC