EZTV Website Down
Incident Report for Popcorn Time
Resolved
This incident has been resolved.
Posted almost 3 years ago. Dec 12, 2014 - 13:15 UTC
Identified
Just so everyone is aware, with the downtime EZTV is experiencing, TV Show updates will be delayed. Sorry for this inconvenience.
Posted almost 3 years ago. Dec 10, 2014 - 09:36 UTC