Unscheduled Maintainence
Incident Report for Popcorn Time
Resolved
Unscheduled maintenance is complete and France should be back online! Sorry for the inconvenience.
Posted about 3 years ago. Nov 19, 2014 - 22:37 UTC
Identified
We are having to deal with some unscheduled maintenance in France at the moment. We are aware this is prime time for you guys so we have limited the downtime to just our downloads from the site. This should only affect those connecting from Europe. Will be no more than 5 minutes.
Posted about 3 years ago. Nov 19, 2014 - 22:30 UTC