Discuss and Blog Downtime
Incident Report for Popcorn Time
Resolved
Blog and Forums back online! There just seems to keep on being more and more of you guys joining our community! Its great and all, but our servers take a beating ;-) Should be back up for good now!
Posted about 3 years ago. Oct 16, 2014 - 12:18 UTC
Identified
We are working on solving some connectivity issues to our Blog and Forum servers.
Posted about 3 years ago. Oct 15, 2014 - 04:04 UTC