Network outage
Incident Report for Popcorn Time
Resolved
This incident has been resolved.
Posted almost 3 years ago. Oct 20, 2014 - 22:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted almost 3 years ago. Oct 20, 2014 - 21:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted almost 3 years ago. Oct 20, 2014 - 21:13 UTC